guix/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
Efraim Flashner 02d5912062
gnu: julia: Update to 1.8.3.
* gnu/packages/julia.scm (julia): Update to 1.8.3.
[source]: Remove one patch.
[arguments]: Adjust 'prepare-deps phase to changes in inputs. Remove
custom 'use-system-libwhich, 'change-number-of-precompiled-statements,
'symlink-libraries phases. In 'fix-include-and-link-paths phase remove
substitution for utf8proc linking and adjust libuv linking. Fix
reference to shell in 'replace-default-shell phase. Adjust the
'shared-objects-path phase to changes in the source. Change the
'enable-parallel-tests phase for upstream changes. Adjust the
'adjust-test-suite phase to be more robust. Change the
'disable-broken-tests phase to help the test suite pass. Rename
'symlink-llvm-utf8proc phase to 'symlink-missing-libraries and add two
more. Adjust make-flags for changes in shared system libraries. Reorder
make-flags to changes in the source. Except for aarch64, use the
defaults for choosing to use 64-bit blas.
[inputs]: Add libblastrampoline. Replace libgit-1.1 with libgit-1.3,
utf8proc-2.7.1 with utf8proc-2.8.0.
[native-inputs]: Replace python-2 with python.
(libunwind-julia): Update to 1.5.0.
[source]: Update patches.
* gnu/packages/libevent.scm (libuv-julia): Update to 2.0.0-4.e6f0e49.
[arguments]: Also build static library, build position-independent-code.
* gnu/packages/llvm.scm (llvm-julia): Update to llvm-13, following
upstream's build instructions.
* gnu/packages/maths.scm (openlibm): Update to 0.8.1.
* gnu/packages/textutils.scm (utf8proc-2.7.1): Update and rename to
utf8proc-2.8.0.
[native-inputs]: Update unicode to 14.0.0.
* gnu/packages/tls.scm (mbedtls-apache): Update to 2.28.0.
[source]: Remove snippet.
[arguments]: Remove trailing #t from phases.
* gnu/packages/patches/julia-allow-parallel-build.patch,
(julia-patch): Update version string to 1.8.2.
gnu/packages/patches/libunwind-julia-fix-GCC10-fno-common.patch: Remove
files.
* gnu/local.mk (dist_patch_DATA): Remove them.

Co-authored-by: Akira Kyle <akira@akirakyle.com>
2022-12-08 19:53:16 +02:00

24 lines
714 B
Diff

Fix one of upstream non-determinism, tracked here:
https://github.com/JuliaLang/julia/issues/34115
https://github.com/JuliaLang/julia/issues/25900
Patch by Nicoló Balzarotti <nicolo@nixo.xyz>.
--- a/base/loading.jl
+++ b/base/loading.jl
@@ -1131,7 +1131,10 @@ function _include_dependency(mod::Module, _path::AbstractString)
end
if _track_dependencies[]
@lock require_lock begin
- push!(_require_dependencies, (mod, path, mtime(path)))
+ push!(_require_dependencies,
+ (mod, path,
+ haskey(ENV, "SOURCE_DATE_EPOCH") ?
+ parse(Float64, ENV["SOURCE_DATE_EPOCH"]) : mtime(path)))
end
end
return path, prev
end