guix/gnu/packages/patches/multiqc-fix-git-subprocess-error.patch
Ben Woodcroft a29929b32c
gnu: multiqc: Update to 0.9.
Suggested by Raoul Bonnal <ilpuccio.febo@gmail.com>.

* gnu/packages/bioinformatics.scm (multiqc): Update to 0.9.
[origin]: Add patch.
* gnu/packages/patches/multiqc-fix-git-subprocess-error.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
2016-12-30 17:22:43 +10:00

17 lines
620 B
Diff

Without this patch, the incorrect exception is caught when 'git' is not in
PATH. See https://github.com/ewels/MultiQC/pull/377.
diff --git a/multiqc/utils/config.py b/multiqc/utils/config.py
index 01fa554..4a11793 100755
--- a/multiqc/utils/config.py
+++ b/multiqc/utils/config.py
@@ -28,7 +28,7 @@ try:
git_hash = subprocess.check_output(['git', 'rev-parse', 'HEAD'], stderr=subprocess.STDOUT)
git_hash_short = git_hash[:7]
version = '{} ({})'.format(version, git_hash_short)
-except subprocess.CalledProcessError:
+except (subprocess.CalledProcessError, FileNotFoundError):
pass
os.chdir(cwd)