guix/gnu/packages/patches/binutils-ld-new-dtags.patch
Ludovic Courtès 1ffa7090b9 distro: Change the module name space to (gnu ...).
* distro: Rename to...
* gnu: ... this.  Update module names accordingly.
* Makefile.am: Adjust accordingly.
* po/POTFILES.in: Likewise.
* distro.scm: Search for files under /gnu/packages instead of
  /distro/packages.
* gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
2013-01-18 01:07:31 +01:00

17 lines
573 B
Diff

Turn on --enable-new-dtags by default to make the linker set RUNPATH
instead of RPATH on binaries. This is important because RUNPATH can
be overriden using LD_LIBRARY_PATH at runtime.
Patch from Nixpkgs by Eelco Dolstra <eelco.dolstra@logicblox.com>.
--- binutils/ld/ldmain.c
+++ binutils/ld/ldmain.c
@@ -296,6 +296,7 @@ main (int argc, char **argv)
link_info.allow_undefined_version = TRUE;
link_info.keep_memory = TRUE;
+ link_info.new_dtags = TRUE;
link_info.combreloc = TRUE;
link_info.strip_discarded = TRUE;
link_info.callbacks = &link_callbacks;