guix/gnu/packages/patches/emacs-realgud-fix-configure-ac.patch
Maxim Cournoyer 03592a6f88
gnu: emacs-realgud: Patch configure.ac to repair the build.
This fixes https://bugs.gnu.org/33196, a build problem caused by a defective
Elisp snippet in a check in configure.ac.

* gnu/packages/patches/emacs-realgud-fix-configure-ac.patch: Add patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/emacs.scm (emacs-realgud)[source]: Use it.
2018-11-15 22:42:35 -05:00

28 lines
820 B
Diff

From a293690f29407ac54a218d6d20c2142e1a0319d1 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Wed, 31 Oct 2018 00:08:34 -0400
Subject: [PATCH] configure.ac: Fix NO_CHECK_EMACS_PACKAGES elisp.
Remove the extraneous trailing parenthesis.
---
configure.ac | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index de0d932..69bcea7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,8 +25,7 @@ AC_MSG_NOTICE("Checking prerequiste packages")
$EMACS -batch -q --no-site-file -eval \
'(dolist (package
(quote (cl-lib loc-changes load-relative test-simple)))
- (require package))
- )'
+ (require package))'
fi
if test $? -ne 0 ; then
AC_MSG_ERROR([Can't continue until above error is corrected.])
--
2.19.0