af6a9fc276
* gnu/packages/python.scm (python-3.8): New public variable. [source]: Add patches to skip four tests. * gnu/packages/patches/python-3.8-search-paths.patch: New file. * gnu/packages/patches/python-3.8-fix-tests.patch: New file. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
17 lines
783 B
Diff
17 lines
783 B
Diff
diff --git a/setup.py b/setup.py
|
|
index 20d7f35..5751083 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -676,8 +676,8 @@ class PyBuildExt(build_ext):
|
|
# if a file is found in one of those directories, it can
|
|
# be assumed that no additional -I,-L directives are needed.
|
|
if not CROSS_COMPILING:
|
|
- self.lib_dirs = self.compiler.library_dirs + system_lib_dirs
|
|
- self.inc_dirs = self.compiler.include_dirs + system_include_dirs
|
|
+ self.lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
|
|
+ self.inc_dirs = os.getenv('CPATH', '').split(os.pathsep)
|
|
else:
|
|
# Add the sysroot paths. 'sysroot' is a compiler option used to
|
|
# set the logical path of the standard system headers and
|
|
--
|
|
2.23.0
|