402e697a11
* gnu/packages/rust.scm (rust-1.48): New variable. Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net>
14 lines
589 B
Diff
14 lines
589 B
Diff
https://github.com/rust-lang/rust/pull/74416
|
|
diff --git a/compiler/rustc_codegen_ssa/src/back/linker.rs b/compiler/rustc_codegen_ssa/src/back/linker.rs
|
|
index 3df956c465e..f45fee45be4 100644
|
|
--- a/compiler/rustc_codegen_ssa/src/back/linker.rs
|
|
+++ b/compiler/rustc_codegen_ssa/src/back/linker.rs
|
|
@@ -28,7 +28,7 @@
|
|
pub fn disable_localization(linker: &mut Command) {
|
|
// No harm in setting both env vars simultaneously.
|
|
// Unix-style linkers.
|
|
- linker.env("LC_ALL", "C");
|
|
+ linker.env("LC_ALL", "en_US.UTF-8");
|
|
// MSVC's `link.exe`.
|
|
linker.env("VSLANG", "1033");
|
|
}
|