0f6f9317ac
* gnu/packages/patches/qemu-build-info-manual.patch: Remove configure script stanza. * gnu/packages/patches/qemu-fix-agent-paths.patch: Adjust patch context. Use execl instead of execle to stay consistent with upstream. * gnu/packages/virtualization.scm (qemu): Update to 7.1.0.
65 lines
2.8 KiB
Diff
65 lines
2.8 KiB
Diff
Allow a QEMU host to set the time and shutdown Guix guests. Styled
|
||
after the patch from the Nix package:
|
||
|
||
https://github.com/NixOS/nixpkgs/blob/master/pkgs/applications/virtualization/qemu/fix-qemu-ga.patch
|
||
|
||
diff --git a/qga/commands-posix.c b/qga/commands-posix.c
|
||
--- a/qga/commands-posix.c
|
||
+++ b/qga/commands-posix.c
|
||
@@ -84,6 +84,7 @@ static void ga_wait_child(pid_t pid, int *status, Error **errp)
|
||
void qmp_guest_shutdown(bool has_mode, const char *mode, Error **errp)
|
||
{
|
||
const char *shutdown_flag;
|
||
+ const char *command;
|
||
Error *local_err = NULL;
|
||
pid_t pid;
|
||
int status;
|
||
@@ -101,10 +102,13 @@ void qmp_guest_shutdown(bool has_mode, const char *mode, Error **errp)
|
||
slog("guest-shutdown called, mode: %s", mode);
|
||
if (!has_mode || strcmp(mode, "powerdown") == 0) {
|
||
shutdown_flag = powerdown_flag;
|
||
+ command = "shutdown";
|
||
} else if (strcmp(mode, "halt") == 0) {
|
||
shutdown_flag = halt_flag;
|
||
+ command = "halt";
|
||
} else if (strcmp(mode, "reboot") == 0) {
|
||
shutdown_flag = reboot_flag;
|
||
+ command = "reboot";
|
||
} else {
|
||
error_setg(errp,
|
||
"mode is invalid (valid values are: halt|powerdown|reboot");
|
||
@@ -123,6 +127,11 @@ void qmp_guest_shutdown(bool has_mode, const char *mode, Error **errp)
|
||
execl("/sbin/shutdown", "shutdown", shutdown_flag, "-g0", "-y",
|
||
"hypervisor initiated shutdown", (char *)NULL);
|
||
#else
|
||
+ /* try Guix’s shutdown/halt/reboot first */
|
||
+ char *path = g_strdup_printf("/run/current-system/profile/sbin/%s", command);
|
||
+ execl(path, command, (char *)NULL);
|
||
+ g_free(path);
|
||
+
|
||
execl("/sbin/shutdown", "shutdown", "-h", shutdown_flag, "+0",
|
||
"hypervisor initiated shutdown", (char *)NULL);
|
||
#endif
|
||
@@ -159,10 +168,12 @@ void qmp_guest_set_time(bool has_time, int64_t time_ns, Error **errp)
|
||
Error *local_err = NULL;
|
||
struct timeval tv;
|
||
static const char hwclock_path[] = "/sbin/hwclock";
|
||
+ static const char hwclock_path_guix[] = "/run/current-system/profile/sbin/hwclock";
|
||
static int hwclock_available = -1;
|
||
|
||
if (hwclock_available < 0) {
|
||
- hwclock_available = (access(hwclock_path, X_OK) == 0);
|
||
+ hwclock_available = (access(hwclock_path_guix, X_OK) == 0) ||
|
||
+ (access(hwclock_path, X_OK) == 0);
|
||
}
|
||
|
||
if (!hwclock_available) {
|
||
@@ -208,6 +219,8 @@ void qmp_guest_set_time(bool has_time, int64_t time_ns, Error **errp)
|
||
|
||
/* Use '/sbin/hwclock -w' to set RTC from the system time,
|
||
* or '/sbin/hwclock -s' to set the system time from RTC. */
|
||
+ execl(hwclock_path_guix, "hwclock", has_time ? "-w" : "-s",
|
||
+ NULL);
|
||
execl(hwclock_path, "hwclock", has_time ? "-w" : "-s", NULL);
|
||
_exit(EXIT_FAILURE);
|
||
} else if (pid < 0) {
|