4a1b3830a8
Fixes <https://issues.guix.gnu.org/63250>. Dante uses dlopen which doesn't work with libc.so but libc.so.6. This fixes socksify, which is patched to skip invoking uname needlessly. * gnu/packages/networking.scm (dante): Enable preloading support. * gnu/packages/patches/dante-non-darwin.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. References: https://github.com/NixOS/nixpkgs/pull/68418#discussion_r343625853 Change-Id: I03a5b6b6e11cf6a0453a4968ff00c6dd627249a8 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
15 lines
483 B
Diff
15 lines
483 B
Diff
Disable runtime check for Darwin so we don't have to substitute uname.
|
|
--- a/bin/socksify.in
|
|
+++ b/bin/socksify.in
|
|
@@ -65,11 +65,6 @@
|
|
unset FULLPATH
|
|
fi
|
|
|
|
-#use "FLAT_NAMESPACE" on Darwin in attempt to match LD_PRELOAD behavior
|
|
-if test x`uname` = xDarwin; then
|
|
- export DYLD_FORCE_FLAT_NAMESPACE=t
|
|
-fi
|
|
-
|
|
#dlib/Makefile.am libtool flags should produce a predictable library name
|
|
#(ending in SOLIB_POSTFIX).
|
|
LIBRARY="${SOCKS_LIBRARY:-${FULLPATH}libdsocks.@SOLIB_POSTFIX@}"
|