0ca1eb705d
* gnu/packages/patches/icecat-CVE-2015-4513-pt01.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt02.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt03.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt04.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt05.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt06.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt07.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt08.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt09.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt10.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt11.patch, gnu/packages/patches/icecat-CVE-2015-7188.patch, gnu/packages/patches/icecat-CVE-2015-7189.patch, gnu/packages/patches/icecat-CVE-2015-7193.patch, gnu/packages/patches/icecat-CVE-2015-7194.patch, gnu/packages/patches/icecat-CVE-2015-7196.patch, gnu/packages/patches/icecat-CVE-2015-7197.patch, gnu/packages/patches/icecat-CVE-2015-7198.patch, gnu/packages/patches/icecat-CVE-2015-7199.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
41 lines
1.6 KiB
Diff
41 lines
1.6 KiB
Diff
From 544bc596ac085ee1adc0b3d7ea793bc37d747ce2 Mon Sep 17 00:00:00 2001
|
|
From: Carsten Book <cbook@mozilla.com>
|
|
Date: Mon, 19 Oct 2015 08:49:46 +0200
|
|
Subject: [PATCH] Bug 1213979 - h2 paket formats. r=hurley, a=al
|
|
|
|
--HG--
|
|
extra : source : 551a28778624d4aff67b698952b1b3e011fc21f7
|
|
extra : intermediate-source : ed67ac61d1c0e4a23888abe3abd3f4636757e038
|
|
---
|
|
netwerk/protocol/http/Http2Stream.cpp | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/netwerk/protocol/http/Http2Stream.cpp b/netwerk/protocol/http/Http2Stream.cpp
|
|
index 38fc025..340eccf 100644
|
|
--- a/netwerk/protocol/http/Http2Stream.cpp
|
|
+++ b/netwerk/protocol/http/Http2Stream.cpp
|
|
@@ -629,9 +629,9 @@ Http2Stream::AdjustInitialWindow()
|
|
return;
|
|
}
|
|
|
|
- uint8_t *packet = mTxInlineFrame.get() + mTxInlineFrameUsed;
|
|
EnsureBuffer(mTxInlineFrame, mTxInlineFrameUsed + Http2Session::kFrameHeaderBytes + 4,
|
|
mTxInlineFrameUsed, mTxInlineFrameSize);
|
|
+ uint8_t *packet = mTxInlineFrame.get() + mTxInlineFrameUsed;
|
|
mTxInlineFrameUsed += Http2Session::kFrameHeaderBytes + 4;
|
|
|
|
mSession->CreateFrameHeader(packet, 4,
|
|
@@ -661,9 +661,9 @@ Http2Stream::AdjustPushedPriority()
|
|
if (mPushSource->RecvdFin() || mPushSource->RecvdReset())
|
|
return;
|
|
|
|
- uint8_t *packet = mTxInlineFrame.get() + mTxInlineFrameUsed;
|
|
EnsureBuffer(mTxInlineFrame, mTxInlineFrameUsed + Http2Session::kFrameHeaderBytes + 5,
|
|
mTxInlineFrameUsed, mTxInlineFrameSize);
|
|
+ uint8_t *packet = mTxInlineFrame.get() + mTxInlineFrameUsed;
|
|
mTxInlineFrameUsed += Http2Session::kFrameHeaderBytes + 5;
|
|
|
|
mSession->CreateFrameHeader(packet, 5,
|
|
--
|
|
2.5.0
|
|
|