guix/gnu/packages/patches/libtiff-CVE-2017-9936.patch
Alex Vong dab536fe1a
gnu: libtiff: Fix CVE-2017-{9936,10688}.
* gnu/packages/patches/libtiff-CVE-2017-9936.patch,
gnu/packages/patches/libtiff-CVE-2017-10688.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/image.scm (libtiff-4.0.8)[source]: Use them.

Signed-off-by: Leo Famulari <leo@famulari.name>
2017-07-07 00:06:37 -04:00

48 lines
1.5 KiB
Diff

Fix CVE-2017-9936:
http://bugzilla.maptools.org/show_bug.cgi?id=2706
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9936
https://security-tracker.debian.org/tracker/CVE-2017-9936
Patch lifted from upstream source repository (the changes to 'ChangeLog'
don't apply to the libtiff 4.0.8 release tarball).
3rd party Git reference:
https://github.com/vadz/libtiff/commit/fe8d7165956b88df4837034a9161dc5fd20cf67a
2017-06-26 Even Rouault <even.rouault at spatialys.com>
* libtiff/tif_jbig.c: fix memory leak in error code path of
JBIGDecode()
Fixes http://bugzilla.maptools.org/show_bug.cgi?id=2706
Reported by team OWL337
/cvs/maptools/cvsroot/libtiff/ChangeLog,v <-- ChangeLog
new revision: 1.1254; previous revision: 1.1253
/cvs/maptools/cvsroot/libtiff/libtiff/tif_jbig.c,v <-- libtiff/tif_jbig.c
new revision: 1.16; previous revision: 1.15
Index: libtiff/libtiff/tif_jbig.c
===================================================================
RCS file: /cvs/maptools/cvsroot/libtiff/libtiff/tif_jbig.c,v
retrieving revision 1.15
retrieving revision 1.16
diff -u -r1.15 -r1.16
--- libtiff/libtiff/tif_jbig.c 10 Mar 2010 18:56:48 -0000 1.15
+++ libtiff/libtiff/tif_jbig.c 26 Jun 2017 15:20:00 -0000 1.16
@@ -1,4 +1,4 @@
-/* $Id: tif_jbig.c,v 1.15 2010-03-10 18:56:48 bfriesen Exp $ */
+/* $Id: tif_jbig.c,v 1.16 2017-06-26 15:20:00 erouault Exp $ */
/*
* Copyright (c) 1988-1997 Sam Leffler
@@ -94,6 +94,7 @@
jbg_strerror(decodeStatus)
#endif
);
+ jbg_dec_free(&decoder);
return 0;
}