guix/gnu/packages/patches/serf-python3.patch
Marius Bakke f6f6e1efee
gnu: serf: Build with Python 3.
* gnu/packages/patches/serf-python3.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/web.scm (serf)[source](patches): New field.
[arguments]: Remove #:scons.
2020-12-19 22:53:00 +01:00

30 lines
1 KiB
Diff

Fix build with Python 3 scons.
Patch taken from Arch Linux:
https://github.com/archlinux/svntogit-packages/blob/packages/serf/trunk/scons-python3.patch
--- serf-1.3.9/SConstruct.orig 2019-07-26 17:49:30.910189251 +0000
+++ serf-1.3.9/SConstruct 2019-07-26 17:49:54.073821735 +0000
@@ -163,9 +163,9 @@
suffix='.def', src_suffix='.h')
})
-match = re.search('SERF_MAJOR_VERSION ([0-9]+).*'
- 'SERF_MINOR_VERSION ([0-9]+).*'
- 'SERF_PATCH_VERSION ([0-9]+)',
+match = re.search(b'SERF_MAJOR_VERSION ([0-9]+).*'
+ b'SERF_MINOR_VERSION ([0-9]+).*'
+ b'SERF_PATCH_VERSION ([0-9]+)',
env.File('serf.h').get_contents(),
re.DOTALL)
MAJOR, MINOR, PATCH = [int(x) for x in match.groups()]
@@ -183,7 +183,7 @@
unknown = opts.UnknownVariables()
if unknown:
- print 'Warning: Used unknown variables:', ', '.join(unknown.keys())
+ print ('Warning: Used unknown variables:', ', '.join(unknown.keys()))
apr = str(env['APR'])
apu = str(env['APU'])