b810a85019
This reinstates and adjusts
commit e3d0fcbf7e
.
* gnu/packages/patches/gcc-libiberty-printf-decl.patch: New file.
* gnu/packages/gcc.scm (gcc-5)[source]: Use it.
[patches]: Add "gcc-arm-bug-71399.patch".
(gcc): Switch to GCC-5.
* gnu/packages/commencement.scm (libstdc++-boot0): New variable.
(gcc-boot0)[inputs]: Add it.
(gcc-toolchain-4.9): Switch to GCC-4.9.
(gcc-toolchain-5): Switch to GCC-FINAL.
* gnu/local.mk (dist_patch_DATA): Add 'gcc-libiberty-printf-decl.patch'.
28 lines
1.4 KiB
Diff
28 lines
1.4 KiB
Diff
This patch makes the exeception specifier of libiberty's 'asprintf'
|
|
and 'vasprintf' declarations match those of glibc to work around the
|
|
problem described at <https://gcc.gnu.org/ml/gcc-help/2016-04/msg00039.html>.
|
|
|
|
The problem in part stems from the fact that libiberty is configured
|
|
without _GNU_SOURCE (thus, it sets HAVE_DECL_ASPRINTF to 0), whereas libcc1
|
|
is configured and built with _GNU_SOURCE, hence the conflicting declarations.
|
|
|
|
--- gcc-5.3.0/include/libiberty.h 2016-04-23 22:45:46.262709079 +0200
|
|
+++ gcc-5.3.0/include/libiberty.h 2016-04-23 22:45:37.110635439 +0200
|
|
@@ -625,7 +625,7 @@ extern int pwait (int, int *, int);
|
|
/* Like sprintf but provides a pointer to malloc'd storage, which must
|
|
be freed by the caller. */
|
|
|
|
-extern int asprintf (char **, const char *, ...) ATTRIBUTE_PRINTF_2;
|
|
+extern int asprintf (char **, const char *, ...) __THROWNL ATTRIBUTE_PRINTF_2;
|
|
#endif
|
|
|
|
/* Like asprintf but allocates memory without fail. This works like
|
|
@@ -637,7 +637,7 @@ extern char *xasprintf (const char *, ..
|
|
/* Like vsprintf but provides a pointer to malloc'd storage, which
|
|
must be freed by the caller. */
|
|
|
|
-extern int vasprintf (char **, const char *, va_list) ATTRIBUTE_PRINTF(2,0);
|
|
+extern int vasprintf (char **, const char *, va_list) __THROWNL ATTRIBUTE_PRINTF(2,0);
|
|
#endif
|
|
|
|
/* Like vasprintf but allocates memory without fail. This works like
|