guix/gnu/packages/patches/mariadb-cmake-compat.patch
Marius Bakke 1539af46d0
gnu: CMake: Update to 3.20.2.
* gnu/packages/cmake.scm (%common-disabled-tests): Don't disable BootstrapTest.
(cmake-bootstrap): Update to 3.20.2.
[source](modules, snippet): Move from here ...
(cmake-minimal)[source]: ... to here.
* gnu/packages/patches/mariadb-cmake-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/databases.scm (mariadb)[source](patches): Add it.
2021-05-09 23:43:32 +02:00

17 lines
607 B
Diff

Fix if statement that triggers syntax error in CMake 3.20 and later.
Taken from upstream:
https://github.com/mariadb-corporation/mariadb-connector-c/commit/242cab8c
diff --git a/libmariadb/cmake/ConnectorName.cmake b/libmariadb/cmake/ConnectorName.cmake
--- a/libmariadb/cmake/ConnectorName.cmake
+++ b/libmariadb/cmake/ConnectorName.cmake
@@ -22,7 +22,7 @@ IF(CMAKE_SYSTEM_NAME MATCHES "Windows")
SET(MACHINE_NAME "x64")
ELSE()
SET(MACHINE_NAME "32")
- END()
+ ENDIF()
ENDIF()
SET(product_name "mysql-connector-c-${CPACK_PACKAGE_VERSION}-${PLATFORM_NAME}${CONCAT_SIGN}${MACHINE_NAME}")