guix/gnu/packages/patches/libjami-ac-config-files.patch
Maxim Cournoyer 8237f4e997
gnu: jami: Update to 20231222.2.
* gnu/packages/jami.scm (%jami-version): Rename to...
(%jami-nightly-version): ... this.  Update to 20231222.2.
(%jami-daemon-commit): New variable.
(%jami-sources): Delete variable.
(libjami) Adjust source to use %jami-nightly-version, %jami-daemon-commit.
[source]: Fetch from git.  Apply libjami-ac-config-files.patch.
[arguments] <make-flags>: Skip ut_media_player test.
<phases>: Add extend-scheduler-test-timeout and extend-scheduler-test-timeout
phases.
[inputs]: Replace dbus-c++ with sdbus-c++.
Add dhtnet.  Replace libgit2 with libgit2-1.6.
(jami): Set version to %jami-nightly-version.
[source]: Fetch from git.  Apply new jami-qml-tests-discovery.patch,
jami-skip-tests-requiring-internet.patch and jami-unbundle-dependencies.patch
patches.
[arguments] <configure-flags>: Add -DWITH_DAEMON_SUBMODULE=OFF.
<phases>: Delete change-directory/maybe.
Adjust check phase.  Add fake-x11-environment,
copy-3rdparty-source-dependencies and disable-problematic-tests phases.
[inputs]: Add md4c and tidy-html.
* gnu/packages/patches/jami-qml-tests-discovery.patch: New file.
* gnu/packages/patches/libjami-ac-config-files.patch: Likewise.
* gnu/packages/patches/jami-skip-tests-requiring-internet.patch: Likewise.
* gnu/packages/patches/jami-unbundle-dependencies.patch: Likewise.
* gnu/packages/patches/jami-libjami-headers-search.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Update accordingly.
* gnu/packages/patches/jami-disable-integration-tests.patch: Adjust patch.

Series-changes: 2
 - Update Jami to latest nightly version (20231222.2)

Change-Id: If30f1178bdfa29c4ea3e54dbb7997e360788adae
2024-01-09 22:10:13 -05:00

53 lines
2.1 KiB
Diff

Forwarded here: https://lists.gnu.org/archive/html/jami/2024-01/msg00003.html
From 20a1702d881b381979d31c456f1b8cf5e0f728ad Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Sun, 7 Jan 2024 16:40:41 -0500
Subject: [PATCH] configure.ac: Expand AC_CONFIG_FILES to fix a race.
The commands apparently run for each file listed, or something
similar, leading to:
configure: creating ./config.status
config.status: creating test/agent/Makefile
chmod: cannot access 'test/agent/pre-inst-env': No such file or directory
chmod: cannot access 'test/agent/scenarios/bulk-calls/run-scenario': No such file or directory
config.status: creating test/agent/pre-inst-env
chmod: cannot access 'test/agent/scenarios/bulk-calls/run-scenario': No such file or directory
* configure.ac [ENABLE_AGENT]: Separate AC_CONFIG_FILES uses per file.
Series-to: jami@gnu.org
Series-postfix: daemon
Change-Id: Ib283955b73540248e09bf31ef44ef3d178b216fa
---
configure.ac | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/configure.ac b/configure.ac
index cdea5ff1c..2ab96d817 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,11 +61,11 @@ AC_ARG_ENABLE([agent],
[Build agent]))
AM_CONDITIONAL([ENABLE_AGENT], [test "x$enable_agent" = "xyes"])
AM_COND_IF([ENABLE_AGENT],
- [AC_CONFIG_FILES([test/agent/Makefile
- test/agent/pre-inst-env:test/agent/build-aux/pre-inst-env.in
- test/agent/scenarios/bulk-calls/run-scenario],
- [chmod +x test/agent/pre-inst-env
- chmod +x test/agent/scenarios/bulk-calls/run-scenario])])
+ [AC_CONFIG_FILES([test/agent/Makefile])
+ AC_CONFIG_FILES([test/agent/pre-inst-env:test/agent/build-aux/pre-inst-env.in],
+ [chmod +x test/agent/pre-inst-env])
+ AC_CONFIG_FILES([test/agent/scenarios/bulk-calls/run-scenario],
+ [chmod +x test/agent/scenarios/bulk-calls/run-scenario])])
AC_ARG_ENABLE([tracepoints], AS_HELP_STRING([--enable-tracepoints], [Enable tracepoints]))
base-commit: e246fb2e090c9b3de55e2d455eee5a6f05a5b286
--
2.41.0