guix/gnu/packages/patches/python-3-search-paths.patch
Marius Bakke 4e3a7d8461
gnu: Python: Consolidate test patches.
While at it, adjust patches for -p1 patch flag.

* gnu/packages/patches/python-fix-tests.patch: Delete file.  Move contents ...
* gnu/packages/patches/python-3-fix-tests.patch: ... here.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/python.scm (python-3.7)[source](patches): Remove obsolete.
[source](patch-flags): Remove.
* gnu/packages/patches/python-3-deterministic-build-info.patch,
gnu/packages/patches/python-3-search-paths.patch: Adjust for `patch -p1`.
2019-02-23 20:44:36 +01:00

17 lines
831 B
Diff

Make sure the build system honors CPATH and LIBRARY_PATH when
looking for headers and libraries.
--- a/setup.py 2015-10-07 23:32:58.891329173 +0200
+++ b/setup.py 2015-10-07 23:46:29.653349924 +0200
@@ -575,8 +575,8 @@
# if a file is found in one of those directories, it can
# be assumed that no additional -I,-L directives are needed.
if not cross_compiling:
- lib_dirs = self.compiler.library_dirs + system_lib_dirs
- inc_dirs = self.compiler.include_dirs + system_include_dirs
+ lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
+ inc_dirs = os.getenv('CPATH', '').split(os.pathsep)
else:
# Add the sysroot paths. 'sysroot' is a compiler option used to
# set the logical path of the standard system headers and