6a20289d5a
* gnu/packages/patches/python-2.7-search-paths.patch, gnu/packages/patches/python-3-search-paths.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/python.scm (python-2)[source]: Use first patch. [arguments]: Remove now unneeded CPPFLAGS and LDFLAGS. (python)[source]: Use second patch. (python-minimal)[arguments]: Remove CPPFLAGS and LDFLAGS.
16 lines
778 B
Diff
16 lines
778 B
Diff
Make sure the build system honors CPATH and LIBRARY_PATH when looking for
|
|
headers and libraries.
|
|
|
|
--- Python-2.7.10/setup.py 2015-10-07 18:33:18.125153186 +0200
|
|
+++ Python-2.7.10/setup.py 2015-10-07 18:33:47.497347552 +0200
|
|
@@ -526,6 +526,10 @@ class PyBuildExt(build_ext):
|
|
inc_dirs += ['/system/include', '/atheos/autolnk/include']
|
|
inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
|
|
|
|
+ # Always honor these variables.
|
|
+ lib_dirs += os.getenv('LIBRARY_PATH', '').split(os.pathsep)
|
|
+ inc_dirs += os.getenv('CPATH', '').split(os.pathsep)
|
|
+
|
|
# OSF/1 and Unixware have some stuff in /usr/ccs/lib (like -ldb)
|
|
if host_platform in ['osf1', 'unixware7', 'openunix8']:
|
|
lib_dirs += ['/usr/ccs/lib']
|