guix/gnu/packages/patches/gdm-default-session.patch
Kei Kebreau 45b320d9f8
gnu: gdm: Update patch for GDM 3.34.
* gnu/packages/patches/gdm-default-session.patch: Update patch for new version
of GDM.
2020-04-18 18:36:00 -04:00

90 lines
3.6 KiB
Diff

This patch ensures '.desktop' files are picked up in the system profile
and not in the directories listed in $XDG_DATA_DIRS. The latter includes
'gnome-session.desktop', which should be used if it's in
/run/current-system/profile, and only then.
Fixes <https://bugs.gnu.org/37831>.
diff -ur a/daemon/gdm-session.c b/daemon/gdm-session.c
--- a/daemon/gdm-session.c 2019-09-25 10:40:24.000000000 -0400
+++ b/daemon/gdm-session.c 2020-04-18 18:30:02.671856808 -0400
@@ -348,24 +348,18 @@
GArray *search_array = NULL;
char **search_dirs;
int i;
- const gchar * const *system_data_dirs = g_get_system_data_dirs ();
static const char *x_search_dirs[] = {
"/etc/X11/sessions/",
DMCONFDIR "/Sessions/",
DATADIR "/gdm/BuiltInSessions/",
- DATADIR "/xsessions/",
+ "/run/current-system/profile/share/xsessions/"
};
static const char *wayland_search_dir = DATADIR "/wayland-sessions/";
search_array = g_array_new (TRUE, TRUE, sizeof (char *));
- for (i = 0; system_data_dirs[i]; i++) {
- gchar *dir = g_build_filename (system_data_dirs[i], "xsessions", NULL);
- g_array_append_val (search_array, dir);
- }
-
g_array_append_vals (search_array, x_search_dirs, G_N_ELEMENTS (x_search_dirs));
#ifdef ENABLE_WAYLAND_SUPPORT
@@ -373,16 +367,7 @@
#ifdef ENABLE_USER_DISPLAY_SERVER
g_array_prepend_val (search_array, wayland_search_dir);
- for (i = 0; system_data_dirs[i]; i++) {
- gchar *dir = g_build_filename (system_data_dirs[i], "wayland-sessions", NULL);
- g_array_insert_val (search_array, i, dir);
- }
#else
- for (i = 0; system_data_dirs[i]; i++) {
- gchar *dir = g_build_filename (system_data_dirs[i], "wayland-sessions", NULL);
- g_array_append_val (search_array, dir);
- }
-
g_array_append_val (search_array, wayland_search_dir);
#endif
}
diff -ur a/libgdm/gdm-sessions.c b/libgdm/gdm-sessions.c
--- a/libgdm/gdm-sessions.c 2019-10-07 04:53:35.000000000 -0400
+++ b/libgdm/gdm-sessions.c 2020-04-18 18:31:42.491348691 -0400
@@ -245,19 +245,12 @@
"/etc/X11/sessions/",
DMCONFDIR "/Sessions/",
DATADIR "/gdm/BuiltInSessions/",
- DATADIR "/xsessions/",
+ "/run/current-system/profile/share/xsessions/"
};
names_seen_before = g_hash_table_new (g_str_hash, g_str_equal);
xorg_search_array = g_ptr_array_new_with_free_func (g_free);
- const gchar * const *system_data_dirs = g_get_system_data_dirs ();
-
- for (i = 0; system_data_dirs[i]; i++) {
- session_dir = g_build_filename (system_data_dirs[i], "xsessions", NULL);
- g_ptr_array_add (xorg_search_array, session_dir);
- }
-
for (i = 0; i < G_N_ELEMENTS (xorg_search_dirs); i++) {
g_ptr_array_add (xorg_search_array, g_strdup (xorg_search_dirs[i]));
}
@@ -269,11 +262,6 @@
wayland_search_array = g_ptr_array_new_with_free_func (g_free);
- for (i = 0; system_data_dirs[i]; i++) {
- session_dir = g_build_filename (system_data_dirs[i], "wayland-sessions", NULL);
- g_ptr_array_add (wayland_search_array, session_dir);
- }
-
for (i = 0; i < G_N_ELEMENTS (wayland_search_dirs); i++) {
g_ptr_array_add (wayland_search_array, g_strdup (wayland_search_dirs[i]));
}