guix/gnu/packages/patches/python2-rdflib-drop-sparqlwrapper.patch
Andreas Enge da71f145c6 gnu: Add python2-rdflib.
* gnu/packages/rdf.scm (python2-rdflib): New variable.
  (python-rdflib): Add patch.
* gnu/packages/patches/python2-rdflib-drop-sparqlwrapper.patch: New file.
* gnu-system.am (dist_patch_DATA): Register patch.
2015-02-25 00:58:20 +01:00

17 lines
604 B
Diff

Drop SPARQLWrapper from the required install inputs under Python 2, as it
creates a circular dependency.
diff -u rdflib-4.1.2.alt/setup.py rdflib-4.1.2/setup.py
--- rdflib-4.1.2.alt/setup.py 2014-03-04 12:40:26.000000000 +0100
+++ rdflib-4.1.2/setup.py 2015-01-23 21:52:59.000000000 +0100
@@ -52,7 +52,7 @@
kwargs['test_suite'] = "nose.collector"
kwargs['install_requires'] = [
'isodate',
- 'pyparsing', 'SPARQLWrapper']
+ 'pyparsing']
if sys.version_info[1]<7: # Python 2.6
kwargs['install_requires'].append('ordereddict')