guix/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
Paul A. Patience 26e9725c54
gnu: Add cl-eazy-gnuplot.
* gnu/packages/lisp-xyz.scm (sbcl-eazy-gnuplot, cl-eazy-gnuplot,
  ecl-eazy-gnuplot): New variables.
* gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch:
  New file.
* gnu/local.mk (dist_patch_DATA): Register it.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
2023-03-07 11:18:50 +01:00

15 lines
617 B
Diff

Don't check whether gnuplot is present in $PATH, because we know it is.
diff --git a/eazy-gnuplot.asd b/eazy-gnuplot.asd
index 7b1c09b..4657cd6 100644
--- a/eazy-gnuplot.asd
+++ b/eazy-gnuplot.asd
@@ -37,7 +37,4 @@
:fill-pointer t)))
(setf (fill-pointer seq) (read-sequence seq stream))
seq)))
- :perform (load-op :before (op c)
- (unless (zerop (nth-value 2 (uiop:run-program "which gnuplot" :ignore-error-status t)))
- (warn "Could not find GNUPLOT in $PATH")))
:in-order-to ((test-op (test-op eazy-gnuplot.test))))