guix/gnu/packages/patches/openjdk-currency-time-bomb2.patch
Ricardo Wurmus fc891f004a
gnu: openjdk10: Fix time bomb in ‘GenerateCurrencyData.java’.
Fixes <https://issues.guix.gnu.org/68333>, as well.
This is a companion to commit 5c0f77f424.

* gnu/packages/java.scm (openjdk10)[source]: Add patch.
* gnu/packages/patches/openjdk-currency-time-bomb2.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Change-Id: I42fc14d305883f672cd6764a0ee6462852e41a5b
2024-01-10 22:09:49 +01:00

14 lines
859 B
Diff

Fix a time bomb present in the OpenJDK tools.
--- a/make/jdk/src/classes/build/tools/generatecurrencydata/GenerateCurrencyData.java
+++ b/make/jdk/src/classes/build/tools/generatecurrencydata/GenerateCurrencyData.java
@@ -285,7 +285,7 @@ public class GenerateCurrencyData {
String timeString = currencyInfo.substring(4, length - 4);
long time = format.parse(timeString).getTime();
if (Math.abs(time - System.currentTimeMillis()) > ((long) 10) * 365 * 24 * 60 * 60 * 1000) {
- throw new RuntimeException("time is more than 10 years from present: " + time);
+ System.err.println("note: time is more than 10 years from \"present\": " + time);
}
specialCaseCutOverTimes[specialCaseCount] = time;
specialCaseOldCurrencies[specialCaseCount] = oldCurrency;