guix/gnu/packages/patches/converseen-hide-non-free-pointers.patch
Nicolas Goaziou 121de47dec
gnu: converseen: Update to 0.12.0.2.
* gnu/packages/image.scm (converseen): Update to 0.12.0.2.
[arguments]<#:configure-flags>: Use Qt6.
[native-inputs, inputs]: Use Qt6.
* gnu/packages/patches/converseen-hide-non-free-pointers.patch: Update patch.

Change-Id: I6b6dc200b1b98115400854b2ff77cc805df45078
2024-01-21 15:48:36 +01:00

278 lines
8.8 KiB
Diff

Remove pointers to PayPal and Facebook.
Upstream status: Guix-specific, not forwarded upstream.
diff --git a/src/dialoginfo.cpp b/src/dialoginfo.cpp
index 52dd628..b37c413 100755
--- a/src/dialoginfo.cpp
+++ b/src/dialoginfo.cpp
@@ -33,7 +33,6 @@ DialogInfo::DialogInfo(QWidget *parent) :
setupUi(this);
connect(pushClose, SIGNAL(clicked()), this, SLOT(close()));
- connect(pushFacebook, SIGNAL(clicked()), this, SLOT(openFacebookPage()));
QString appVersion;
QString magickVersion;
@@ -66,62 +65,4 @@ DialogInfo::DialogInfo(QWidget *parent) :
.arg(qtVersionStrTr)
.arg(QT_VERSION_STR);
labelQtVersion->setText(qt_versionString);
-
- // This section generates a Text + Png pixmap icon for the donazion button!
-
- QString donateText = tr("Make a Donation!");
- QString donateDescriptionText = tr("Donate using PayPal, Ko-Fi or Cryptocurrencies.");
-
- QString htmlDonationText = QString(R"(
- <style>
- table {
- border-collapse: collapse;
- }
- td {
- text-align: center;
- vertical-align: middle;
- padding: 5px;
- }
- </style>
-
- <table>
- <tr>
- <td><img src=':/Images/res/heart.png' width='52' height='52'></td>
- <td>
- <span style='font-weight: bold; font-size:18pt; text-align: center;'>%1</span><br />
- <span style='font-style: italic; font-size:8pt; text-align: center;'>%2</span>
- </td>
- </tr>
- </table>
- )")
- .arg(donateText, donateDescriptionText);
-
- QTextDocument donateHtmlText;
- donateHtmlText.setHtml(htmlDonationText);
-
- QPixmap pixmapDonationText(donateHtmlText.size().width(), donateHtmlText.size().height());
- pixmapDonationText.fill( Qt::transparent );
-
- QPainter painter( &pixmapDonationText );
- painter.setRenderHint(QPainter::Antialiasing, true);
-
- donateHtmlText.drawContents(&painter, pixmapDonationText.rect());
-
- QIcon donateButtonIcon(pixmapDonationText);
- pushDonatePayPal->setIcon(donateButtonIcon);
- pushDonatePayPal->setIconSize(pixmapDonationText.rect().size());
-
- adjustSize();
- this->resize(512, 800);
-}
-
-void DialogInfo::openFacebookPage()
-{
- QDesktopServices::openUrl(QUrl("https://www.facebook.com/converseen", QUrl::TolerantMode));
}
-
-void DialogInfo::on_pushDonatePayPal_clicked()
-{
- QDesktopServices::openUrl(QUrl("https://converseen.fasterland.net/donate/", QUrl::TolerantMode));
-}
-
diff --git a/src/dialoginfo.h b/src/dialoginfo.h
index 4d8ba15..ef6afa9 100755
--- a/src/dialoginfo.h
+++ b/src/dialoginfo.h
@@ -32,8 +32,6 @@ public:
DialogInfo(QWidget *parent = 0);
private slots:
- void openFacebookPage();
- void on_pushDonatePayPal_clicked();
};
#endif // DIALOGINFO_H
diff --git a/src/mainwindowimpl.cpp b/src/mainwindowimpl.cpp
index 71ddc2c..bd4294b 100755
--- a/src/mainwindowimpl.cpp
+++ b/src/mainwindowimpl.cpp
@@ -163,7 +163,6 @@ void MainWindowImpl::createActions()
connect(actionConvert, SIGNAL(triggered()), this, SLOT(elabora()));
connect(actionInfo, SIGNAL(triggered()), this, SLOT(about()));
- connect(actionDonatePaypal, SIGNAL(triggered()), this, SLOT(openPaypalLink()));
connect(actionReportBug, SIGNAL(triggered()), this, SLOT(bugReport()));
connect(actionCheckForUpdates, SIGNAL(triggered()), this, SLOT(checkForUpdates()));
connect(actionHelp, SIGNAL(triggered()), this, SLOT(onlineHelp()));
diff --git a/ui/dialoginfo.ui b/ui/dialoginfo.ui
index 2878670..0535a85 100755
--- a/ui/dialoginfo.ui
+++ b/ui/dialoginfo.ui
@@ -273,146 +273,6 @@ p, li { white-space: pre-wrap; }
</layout>
</widget>
</item>
- <item>
- <layout class="QVBoxLayout" name="verticalLayout">
- <item>
- <widget class="QLabel" name="label_18">
- <property name="text">
- <string>&lt;html&gt;&lt;head/&gt;&lt;body&gt;&lt;p align=&quot;center&quot;&gt;&lt;span style=&quot; font-weight:600;&quot;&gt;If you appreciate this work and would like to support the project, you are welcome to donate via PayPal&lt;/span&gt;&lt;/p&gt;&lt;/body&gt;&lt;/html&gt;</string>
- </property>
- <property name="wordWrap">
- <bool>true</bool>
- </property>
- </widget>
- </item>
- <item>
- <layout class="QHBoxLayout" name="horizontalLayout_4">
- <item>
- <spacer name="horizontalSpacer_4">
- <property name="orientation">
- <enum>Qt::Horizontal</enum>
- </property>
- <property name="sizeHint" stdset="0">
- <size>
- <width>40</width>
- <height>20</height>
- </size>
- </property>
- </spacer>
- </item>
- <item>
- <widget class="QPushButton" name="pushDonatePayPal">
- <property name="cursor">
- <cursorShape>PointingHandCursor</cursorShape>
- </property>
- <property name="text">
- <string/>
- </property>
- <property name="iconSize">
- <size>
- <width>150</width>
- <height>50</height>
- </size>
- </property>
- <property name="autoDefault">
- <bool>false</bool>
- </property>
- <property name="flat">
- <bool>true</bool>
- </property>
- </widget>
- </item>
- <item>
- <spacer name="horizontalSpacer_5">
- <property name="orientation">
- <enum>Qt::Horizontal</enum>
- </property>
- <property name="sizeHint" stdset="0">
- <size>
- <width>40</width>
- <height>20</height>
- </size>
- </property>
- </spacer>
- </item>
- </layout>
- </item>
- </layout>
- </item>
- <item>
- <widget class="Line" name="line_2">
- <property name="orientation">
- <enum>Qt::Horizontal</enum>
- </property>
- </widget>
- </item>
- <item>
- <layout class="QHBoxLayout" name="horizontalLayout_5">
- <item>
- <spacer name="horizontalSpacer_2">
- <property name="orientation">
- <enum>Qt::Horizontal</enum>
- </property>
- <property name="sizeHint" stdset="0">
- <size>
- <width>40</width>
- <height>20</height>
- </size>
- </property>
- </spacer>
- </item>
- <item>
- <layout class="QHBoxLayout" name="horizontalLayout_3">
- <item>
- <widget class="QLabel" name="label_7">
- <property name="text">
- <string>&lt;html&gt;&lt;head/&gt;&lt;body&gt;&lt;p&gt;&lt;span style=&quot; font-size:11pt; font-weight:600;&quot;&gt;Follow Converseen:&lt;/span&gt;&lt;/p&gt;&lt;/body&gt;&lt;/html&gt;</string>
- </property>
- </widget>
- </item>
- <item>
- <widget class="QPushButton" name="pushFacebook">
- <property name="cursor">
- <cursorShape>PointingHandCursor</cursorShape>
- </property>
- <property name="text">
- <string/>
- </property>
- <property name="icon">
- <iconset resource="../resources.qrc">
- <normaloff>:/Images/res/facebook-icon.png</normaloff>:/Images/res/facebook-icon.png</iconset>
- </property>
- <property name="iconSize">
- <size>
- <width>32</width>
- <height>32</height>
- </size>
- </property>
- <property name="autoDefault">
- <bool>false</bool>
- </property>
- <property name="flat">
- <bool>true</bool>
- </property>
- </widget>
- </item>
- </layout>
- </item>
- <item>
- <spacer name="horizontalSpacer_3">
- <property name="orientation">
- <enum>Qt::Horizontal</enum>
- </property>
- <property name="sizeHint" stdset="0">
- <size>
- <width>40</width>
- <height>20</height>
- </size>
- </property>
- </spacer>
- </item>
- </layout>
- </item>
<item>
<widget class="Line" name="line">
<property name="orientation">
diff --git a/ui/mainwindow.ui b/ui/mainwindow.ui
index 24bda6f..e8a072d 100755
--- a/ui/mainwindow.ui
+++ b/ui/mainwindow.ui
@@ -1408,18 +1408,6 @@ p, li { white-space: pre-wrap; }
<string>&amp;About</string>
</property>
</action>
- <action name="actionDonatePaypal">
- <property name="icon">
- <iconset resource="../resources.qrc">
- <normaloff>:/Images/res/heart.png</normaloff>:/Images/res/heart.png</iconset>
- </property>
- <property name="text">
- <string>&amp;Donate!</string>
- </property>
- <property name="toolTip">
- <string>Donate via Paypal, Ko-Fi, Cryptocurrencies</string>
- </property>
- </action>
<action name="actionReportBug">
<property name="text">
<string>&amp;Report bug...</string>