guix/gnu/packages/patches/fifengine-swig-compat.patch
Marius Bakke 5afffbeffc
gnu: fifengine: Fix build with newer Swig and Python.
* gnu/packages/patches/fifengine-swig-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/games.scm (fifengine)[source](patches): New field.
[arguments]: Remove hard coded Python version from #:configure-flags.
2020-03-14 12:02:51 +01:00

18 lines
853 B
Diff

Fix build failure when using Swig 4.
Taken from upstream:
https://github.com/fifengine/fifengine/commit/d14f232f4cd9a00b05d6872957070e8c020f515d
diff --git a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -893,7 +893,7 @@ if(build-python)
find_package(PythonLibs ${PYTHON_VERSION_STRING} EXACT)
include_directories(${PYTHON_INCLUDE_PATH})
- set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -nosafecstrings -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -nobuildnone -keyword -w511 -w473 -w404 -w314)
+ set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -keyword -w511 -w473 -w404 -w314)
set_source_files_properties("${PROJECT_BINARY_DIR}/fife.i" PROPERTIES CPLUSPLUS ON)
set(FIFE_SOURCES ${FIFE_CORE_SRC})