guix/gnu/packages/patches/vigra-python-compat.patch

19 lines
638 B
Diff

Fix build with Boost + Python 3.7.
Taken from upstream:
https://github.com/ukoethe/vigra/commit/a6fa62663c6a6b752ed0707e95f643e25867a0f9
diff --git a/vigranumpy/src/core/vigranumpycore.cxx b/vigranumpy/src/core/vigranumpycore.cxx
index ec38d3636..c81c6ae52 100644
--- a/vigranumpy/src/core/vigranumpycore.cxx
+++ b/vigranumpy/src/core/vigranumpycore.cxx
@@ -61,7 +61,7 @@ UInt32 pychecksum(python::str const & s)
return checksum(data, size);
#else
Py_ssize_t size = 0;
- char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
+ const char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
return checksum(data, size);
#endif
}