0ca1eb705d
* gnu/packages/patches/icecat-CVE-2015-4513-pt01.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt02.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt03.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt04.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt05.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt06.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt07.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt08.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt09.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt10.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt11.patch, gnu/packages/patches/icecat-CVE-2015-7188.patch, gnu/packages/patches/icecat-CVE-2015-7189.patch, gnu/packages/patches/icecat-CVE-2015-7193.patch, gnu/packages/patches/icecat-CVE-2015-7194.patch, gnu/packages/patches/icecat-CVE-2015-7196.patch, gnu/packages/patches/icecat-CVE-2015-7197.patch, gnu/packages/patches/icecat-CVE-2015-7198.patch, gnu/packages/patches/icecat-CVE-2015-7199.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
27 lines
1.1 KiB
Diff
27 lines
1.1 KiB
Diff
From cc2a334ee16e99d376fcb49203239abf9eb2c148 Mon Sep 17 00:00:00 2001
|
|
From: Jeff Gilbert <jgilbert@mozilla.com>
|
|
Date: Wed, 7 Oct 2015 13:27:37 -0700
|
|
Subject: [PATCH] Bug 1188010 - Use MOZ_RELEASE_ASSERT when failure means
|
|
overflow. - r=kamidphish, a=abillings
|
|
|
|
---
|
|
dom/canvas/WebGLTexture.cpp | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/dom/canvas/WebGLTexture.cpp b/dom/canvas/WebGLTexture.cpp
|
|
index 60afc45..d6a6ccd 100644
|
|
--- a/dom/canvas/WebGLTexture.cpp
|
|
+++ b/dom/canvas/WebGLTexture.cpp
|
|
@@ -651,8 +651,7 @@ WebGLTexture::EnsureNoUninitializedImageData(TexImageTarget imageTarget,
|
|
imageInfo.mDepth,
|
|
bytespertexel,
|
|
mContext->mPixelStoreUnpackAlignment);
|
|
- MOZ_ASSERT(checked_byteLength.isValid()); // Should have been checked
|
|
- // earlier.
|
|
+ MOZ_RELEASE_ASSERT(checked_byteLength.isValid()); // Should have been checked earlier.
|
|
|
|
// Infallible for now.
|
|
UniquePtr<uint8_t> zeros((uint8_t*)moz_xcalloc(1,
|
|
--
|
|
2.5.0
|
|
|