0ca1eb705d
* gnu/packages/patches/icecat-CVE-2015-4513-pt01.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt02.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt03.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt04.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt05.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt06.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt07.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt08.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt09.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt10.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt11.patch, gnu/packages/patches/icecat-CVE-2015-7188.patch, gnu/packages/patches/icecat-CVE-2015-7189.patch, gnu/packages/patches/icecat-CVE-2015-7193.patch, gnu/packages/patches/icecat-CVE-2015-7194.patch, gnu/packages/patches/icecat-CVE-2015-7196.patch, gnu/packages/patches/icecat-CVE-2015-7197.patch, gnu/packages/patches/icecat-CVE-2015-7198.patch, gnu/packages/patches/icecat-CVE-2015-7199.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
25 lines
724 B
Diff
25 lines
724 B
Diff
From d91a58cb0094d0421439a915be0b4879a45d20d4 Mon Sep 17 00:00:00 2001
|
|
From: Brian Hackett <bhackett1024@gmail.com>
|
|
Date: Mon, 12 Oct 2015 17:15:12 -0600
|
|
Subject: [PATCH] Bug 1209471 - Fix group used for Array.concat result,
|
|
r=jandem. a=al
|
|
|
|
---
|
|
js/src/jsarray.cpp | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/js/src/jsarray.cpp b/js/src/jsarray.cpp
|
|
index 3d574d5..b4ff057 100644
|
|
--- a/js/src/jsarray.cpp
|
|
+++ b/js/src/jsarray.cpp
|
|
@@ -2661,6 +2661,7 @@ js::array_concat(JSContext* cx, unsigned argc, Value* vp)
|
|
narr = NewDenseEmptyArray(cx);
|
|
if (!narr)
|
|
return false;
|
|
+ TryReuseArrayGroup(aobj, narr);
|
|
args.rval().setObject(*narr);
|
|
length = 0;
|
|
}
|
|
--
|
|
2.5.0
|
|
|