guix/gnu/packages/patches/ddclient-skip-test.patch
Bruno Victal fb2bf136f0
gnu: ddclient: Update to 3.10.0.
3.10.0 switched to autotools based build system.

* gnu/packages/dns.scm (ddclient): Update to 3.10.0.
[source]: Patch test-suite to skip tests that require networking.
[build-system]: Switch to gnu-build-system.
[native-inputs]: Remove bash. Move perl to inputs.
[inputs]: Add perl, perl-io-socket-inet6, perl-json. Remove perl-data-validate-ip.
[native-search-paths]: Add $SSL_CERT_DIR, $SSL_CERT_FILE. Required for SSL support.
* gnu/packages/patches/ddclient-skip-test.patch: New file.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2023-02-11 00:09:39 +01:00

44 lines
1.6 KiB
Diff

From e5657802025f238b39581534f3b4d408565c8943 Mon Sep 17 00:00:00 2001
From: Bruno Victal <mirai@makinata.eu>
Date: Sun, 5 Feb 2023 21:05:00 +0000
Subject: [PATCH] Disable sandbox incompatible tests.
See: https://github.com/ddclient/ddclient/issues/465
---
t/get_ip_from_if.pl | 21 ---------------------
1 file changed, 21 deletions(-)
diff --git a/t/get_ip_from_if.pl b/t/get_ip_from_if.pl
index 6f08e5d..d78c3d0 100644
--- a/t/get_ip_from_if.pl
+++ b/t/get_ip_from_if.pl
@@ -39,25 +39,4 @@ subtest "get_ip_from_interface tests" => sub {
}
};
-subtest "Get default interface and IP for test system" => sub {
- my $interface = ddclient::get_default_interface(4);
- if ($interface) {
- isnt($interface, "lo", "Check for loopback 'lo'");
- isnt($interface, "lo0", "Check for loopback 'lo0'");
- my $ip1 = ddclient::get_ip_from_interface("default", 4);
- my $ip2 = ddclient::get_ip_from_interface($interface, 4);
- is($ip1, $ip2, "Check IPv4 from default interface");
- ok(ddclient::is_ipv4($ip1), "Valid IPv4 from get_ip_from_interface($interface)");
- }
- $interface = ddclient::get_default_interface(6);
- if ($interface) {
- isnt($interface, "lo", "Check for loopback 'lo'");
- isnt($interface, "lo0", "Check for loopback 'lo0'");
- my $ip1 = ddclient::get_ip_from_interface("default", 6);
- my $ip2 = ddclient::get_ip_from_interface($interface, 6);
- is($ip1, $ip2, "Check IPv6 from default interface");
- ok(ddclient::is_ipv6($ip1), "Valid IPv6 from get_ip_from_interface($interface)");
- }
-};
-
done_testing();
--
2.38.1