guix/gnu/packages/patches/ruby-safe-yaml-add-require-time.patch
Christopher Baines 28cf8dab3e
gnu: ruby-safe-yaml: Add missing require 'time'.
Patch ruby-safe-yaml to fix an issue that would lead to an error like this:
uninitialized constant SafeYAML::Parse::Date::DateTime

It's been reported upstream [1], and this patch was taken from the upstream Git
repository.

1: https://github.com/dtao/safe_yaml/issues/80

* gnu/packages/ruby.scm (ruby-safe-yaml)[source]: Switch to the Git repository
so that applying patches works and add a patch.
[arguments]: Enable tests and add a phase to set the TZ environment variable,
as one of the tests depends on a certian timezone.
* gnu/packages/patches/ruby-safe-yaml-add-require-time.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add new patch file.
2019-02-14 21:37:52 +00:00

20 lines
537 B
Diff

From 9dd1e8d9ad0396a8c9092c2e9f17d498c58e0208 Mon Sep 17 00:00:00 2001
From: elifoster <elifosterwy@gmail.com>
Date: Tue, 5 Dec 2017 14:30:13 -0800
Subject: [PATCH] Fix uninitialized constant DateTime Close #80
---
lib/safe_yaml/parse/date.rb | 2 ++
1 file changed, 2 insertions(+)
diff --git a/lib/safe_yaml/parse/date.rb b/lib/safe_yaml/parse/date.rb
index cd3c62a..3a30a8b 100644
--- a/lib/safe_yaml/parse/date.rb
+++ b/lib/safe_yaml/parse/date.rb
@@ -1,3 +1,5 @@
+require 'time'
+
module SafeYAML
class Parse
class Date