guix/gnu/packages/patches/libreoffice-boost.patch
Marius Bakke 8576505422
gnu: libreoffice: Fix FTBFS with Boost 1.69.0.
* gnu/packages/patches/libreoffice-boost.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/libreoffice.scm (libreoffice)[source](patches): Add it.
2019-02-02 20:10:18 +01:00

18 lines
522 B
Diff

Fix compatibility with newer Boost.
Extracted from this upstream commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=23a8d5ffbbe58761b89f590f0735abccd69a3681
diff --git a/sfx2/source/appl/shutdownicon.cxx b/sfx2/source/appl/shutdownicon.cxx
--- a/sfx2/source/appl/shutdownicon.cxx
+++ b/sfx2/source/appl/shutdownicon.cxx
@@ -144,7 +144,7 @@ bool LoadModule()
#endif // ENABLE_QUICKSTART_APPLET
}
assert(!boost::logic::indeterminate(loaded));
- return loaded;
+ return bool(loaded);
}
}