guix/gnu/packages/patches/emacs-helpful-fix-docstring-test.patch
yarl baudig 6169c582d1
gnu: emacs-helpful: Update to 0.19
* gnu/packages/patches/emacs-helpful-docstring-test.patch: New file.
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.19.
[source]: Use the patch.
* gnu/local.mk (dist_patch_DATA): Register the patch.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
2022-05-31 06:16:18 +02:00

18 lines
681 B
Diff

This patch fixing a build failure has been cherry-picked from upstream.
Originally submitted as pull request by Erik Šabič.
See also <https://github.com/Wilfred/helpful/pull/296>.
diff --git a/test/helpful-unit-test.el b/test/helpful-unit-test.el
index a07aa8e..8a95129 100644
--- a/test/helpful-unit-test.el
+++ b/test/helpful-unit-test.el
@@ -119,7 +119,9 @@ bar")))
(should
(equal
(helpful--docstring #'test-foo-advised t)
- "Docstring here too.")))
+ (if (version< emacs-version "28")
+ "Docstring here too."
+ "Docstring here too.\n\nThis function has :around advice: `ad-Advice-test-foo-advised'."))))
(defun test-foo-no-docstring ()
nil)