guix/gnu/packages/patches/orc-typedef-enum.patch
Marius Bakke a1d1703a1d
gnu: orc: Fix broken header file.
* gnu/packages/patches/orc-typedef-enum.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/gstreamer.scm (orc)[source](patches): New field.
2019-10-15 18:18:38 +02:00

18 lines
460 B
Diff

Orc 0.4.30 has a bug that causes duplicate symbols due to a missing typedef.
Taken from upstream:
https://gitlab.freedesktop.org/gstreamer/orc/merge_requests/32
diff --git a/orc/orctarget.h b/orc/orctarget.h
--- a/orc/orctarget.h
+++ b/orc/orctarget.h
@@ -19,7 +19,7 @@ enum {
ORC_TARGET_FAST_DENORMAL = (1<<31)
};
-enum {
+typedef enum {
ORC_TARGET_POWERPC_64BIT = (1<<0),
ORC_TARGET_POWERPC_LE = (1<<1),
ORC_TARGET_POWERPC_ALTIVEC = (1<<2),