guix/gnu/packages/patches/kinit-kdeinit-extra_libs.patch
Hartmut Goebel 1dd1076c5e
gnu: kde-frameworks: Update to 5.63.0.
KHolidays is part of frameworks since version 5.43 already.

* gnu/packages/kde.scm(kholidays): Move to …
* gnu/packages/kde-frameworks.scm(kholidays) … here, update to 5.63.0 and
  [source]: Update path.
  (attica, baloo, bluez-qt, breeze- icons,
  extra-cmake-modules, kactivities, kactivities-stats, kapidox, karchive,
  kauth, kbookmarks, kcmutils, kcodecs, kcompletion, kconfig, kcoreaddons,
  kcrash, kdbusaddons, kde-frameworkintegration, kdeclarative, kded,
  kdelibs4support, kdesu, kdnssd, kdoctools, kemoticons, kglobalaccel,
  kguiaddons, khtml, ki18n, kidletime, kimageformats, kinit, kirigami,
  kitemmodels, kitemviews, kjobwidgets, kjs, kjsembed, kmediaplayer,
  knewstuff, knotifications, knotifyconfig, kpackage, kparts, kpeople, kpty,
  kross, krunner, kservice, ksyntaxhighlighting, ktexteditor, kunitconversion,
  kwallet, kwidgetsaddons, kxmlrpcclient, modemmanager-qt, networkmanager-qt,
  oxygen-icons, plasma-framework, prison, qqc2-desktop-style, solid, sonnet,
  threadweaver): Update to 5.63.0.
  (kconfigwidgets): Update to 5.63.0; [inputs]: Add qttools.
  (kdesignerplugin):  Update to 5.63.0; [source]: Update path.
  (kdewebkit): Update to 5.63.0; [source]: Update path.;
  [inputs]: Add qttools.
  (kfilemetadata): Update to 5.63.0; [inputs]: Add kcoreaddons;
  [arguments]<#pahses>: Add a test-case to the blacklist
  (kiconthemes): Update to 5.63.0; [inputs]: Add qttools.
  (kio): Update to 5.63.0; [inputs]: Add qttools.
  (kplotting): Update to 5.63.0; [inputs]: Add qttools.
  (ktextwidgets): Update to 5.63.0; [inputs]: Add qttools.
  (kwayland): Update to 5.63.0; [inputs]: Add wayland-protocols.
  (kwindowsystem): Update to 5.63.0, update blacklist or tests,
  explicitly set XDG_RUNTIME_DIR; [inputs]: Add xcb-util-wm.
  (kxmlgui): Update to 5.63.0; [inputs]: Add qttools.

* gnu/packages/patches/kinit-kdeinit-extra_libs.patch: Adjust.
* gnu/packages/patches/kwindowsystem-qt-compat.patch: Remove obsolete patch.
2019-11-10 22:18:19 +01:00

54 lines
1.8 KiB
Diff

Search the "extra libs" in GUIX_KF5INIT_LIB_PATH (which basically is a
collection of all /lib directories). We can not hard-code the full path to the
libsKF5Plasam, since adding palse-workspace
Adopted from NixOS
pkgs/development/libraries/kde-frameworks/kinit/kdeinit-extra_libs.patch
===================================================================
--- kinit-5.32.0/src/kdeinit/kinit-5.32.0/src/kdeinit/.orig
+++ kinit-5.32.0/src/kdeinit/kinit.cpp
@@ -96,9 +96,9 @@
"libKF5Parts.5.dylib",
"libKF5Plasma.5.dylib"
#else
- "libKF5KIOCore.so.5",
- "libKF5Parts.so.5",
- "libKF5Plasma.so.5"
+ "GUIX_PKGS_KF5_KIO/lib/libKF5KIOCore.so.5",
+ "GUIX_PKGS_KF5_PARTS/lib/libKF5Parts.so.5",
+ "GUIX_PKGS_KF5_PLASMA/lib/libKF5Plasma.so.5"
#endif
};
#endif
@@ -1533,20 +1531,6 @@ static int initXconnection()
}
#endif
-#ifndef Q_OS_OSX
-// Find a shared lib in the lib dir, e.g. libkio.so.
-// Completely unrelated to plugins.
-static QString findSharedLib(const QString &lib)
-{
- QString path = QFile::decodeName(CMAKE_INSTALL_PREFIX "/" LIB_INSTALL_DIR "/") + lib;
- if (QFile::exists(path)) {
- return path;
- }
- // We could also look in LD_LIBRARY_PATH, but really, who installs the main libs in different prefixes?
- return QString();
-}
-#endif
-
extern "C" {
static void secondary_child_handler(int)
@@ -1689,7 +1693,7 @@
if (!d.suicide && qEnvironmentVariableIsEmpty("KDE_IS_PRELINKED")) {
const int extrasCount = sizeof(extra_libs) / sizeof(extra_libs[0]);
for (int i = 0; i < extrasCount; i++) {
- const QString extra = findSharedLib(QString::fromLatin1(extra_libs[i]));
+ const QString extra = QString::fromLatin1(extra_libs[i]);
if (!extra.isEmpty()) {
QLibrary l(extra);
l.setLoadHints(QLibrary::ExportExternalSymbolsHint);