guix/gnu/packages/patches/u-boot-sifive-prevent-reloc-initrd-fdt.patch
Pierre Langlois eb46c6c5c8
gnu: u-boot: Update to 2021.07.
* gnu/packages/patches/u-boot-sifive-prevent-reloc-initrd-fdt.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/bootloaders.scm (%u-boot-sifive-prevent-relocating-initrd-fdt):
New variable.
(u-boot): Update to 2021.07.
[native-inputs]: Add python-pycryptodomex.
(u-boot-2021.07): Delete variable.
(u-boot-tools)[arguments]: Adapt 'patch phase, disable failing test_spl test.
(u-boot-sifive-unmatched): Use default u-boot package.
(u-boot-pinebook-pro-rk3328): Use default u-boot package.
2021-08-02 13:23:32 +01:00

17 lines
741 B
Diff

Description: prevent relocating initrd & fdt, that results in failure to boot
Author: Heinrich Schuchardt (xypron)
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/u-boot/+bug/1937246
Index: u-boot-2021.07~rc4+dfsg/include/configs/sifive-unmatched.h
===================================================================
--- u-boot-2021.07~rc4+dfsg.orig/include/configs/sifive-unmatched.h
+++ u-boot-2021.07~rc4+dfsg/include/configs/sifive-unmatched.h
@@ -62,6 +62,8 @@
"name=system,size=-,bootable,type=${type_guid_gpt_system};"
#define CONFIG_EXTRA_ENV_SETTINGS \
+ "fdt_high=0xffffffffffffffff\0" \
+ "initrd_high=0xffffffffffffffff\0" \
"kernel_addr_r=0x84000000\0" \
"fdt_addr_r=0x88000000\0" \
"scriptaddr=0x88100000\0" \