cb6392698a
* gnu/packages/gl.scm (mesa): Update to 17.2.1. [inputs]: Add WAYLAND-PROTOCOLS. * gnu/packages/patches/mesa-skip-disk-cache-test.patch: Adjust context.
19 lines
738 B
Diff
19 lines
738 B
Diff
disk_cache_create() here looks up the users home directory from <pwd.h>
|
|
which resolves to "/" in the build environment. I could not find an easy
|
|
way to set the home directory to something else, so we disable this test
|
|
for now.
|
|
|
|
--- a/src/compiler/glsl/tests/cache_test.c
|
|
+++ b/src/compiler/glsl/tests/cache_test.c
|
|
@@ -170,11 +170,6 @@
|
|
unsetenv("MESA_GLSL_CACHE_DIR");
|
|
unsetenv("XDG_CACHE_HOME");
|
|
|
|
- cache = disk_cache_create("test", "make_check", 0);
|
|
- expect_non_null(cache, "disk_cache_create with no environment variables");
|
|
-
|
|
- disk_cache_destroy(cache);
|
|
-
|
|
/* Test with XDG_CACHE_HOME set */
|
|
setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
|
|
cache = disk_cache_create("test", "make_check", 0);
|