34cfeca84e
This commit reverts 'patch' hack introduced in
a48a1071a6
and fixes bug in the Clar test
framework.
Patch is proposed to Clar upstream as
<https://github.com/vmg/clar/pull/78>.
* gnu/local.mk: Add libgit2-0.25.1-mtime-0.patch.
* gnu/packages/patches/libgit2-0.25.1-mtime-0.patch: New file.
* gnu/packages/version-control.scm (libgit2)[arguments]:
Remove 'apply-patch' phase.
[inputs]: Remove "patch".
[source]: Add 'patches' field.
Signed-off-by: Sergei Trofimovich <slyfox@inbox.ru>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
14 lines
440 B
Diff
14 lines
440 B
Diff
The Clar test framework has a bug whereby it skips the parsing phase
|
|
on files with mtime=0.
|
|
|
|
Reported upstream at <https://github.com/vmg/clar/pull/78>.
|
|
|
|
diff --git a/tests/generate.py b/tests/generate.py
|
|
index b639c8f..111ca41 100644
|
|
--- a/tests/generate.py
|
|
+++ b/tests/generate.py
|
|
@@ -63,3 +63,3 @@ class Module(object):
|
|
|
|
- self.mtime = 0
|
|
+ self.mtime = None # Guix sets all file mtimes to '0'
|
|
self.enabled = True
|