1b0f266e40
Fixes <https://bugs.gnu.org/27551>. Reported by Leo Famulari <leo@famulari.name>. This reinstates the following commits:e3ddb1e83
* gnu: guile-cairo: Switch to Guile 2.2.ae5c6ef39
* gnu: guile-gnome: Update to 2.16.5.0fd8013fc
* gnu: guile-rsvg: Update to commit 05c6a2fd.66b9183c4
* gnu: guile-lib: Switch to Guile 2.2. and adds the following changes: * gnu/bootloader/grub.scm (svg->png): Add 'package->derivation' call for GUILE-2.2. Pass #:guile-for-build to 'gexp->derivation'. * gnu/build/svg.scm (svg->png): Add 'em' and 'ex' to the 'let-values' form to account for all the values returned by 'rsvg-handle-get-dimensions', which Guile 2.2 does not truncate.
16 lines
619 B
Diff
16 lines
619 B
Diff
This patch fixes a bug in guile-rsvg's build system, whereby the CFLAGS
|
|
and LDFLAGS for Guile would not be captured.
|
|
|
|
--- guile-rsvg-2.18.1/configure.ac 2015-08-31 22:30:30.578909480 +0200
|
|
+++ guile-rsvg-2.18.1/configure.ac 2015-08-31 22:32:15.071516084 +0200
|
|
@@ -39,6 +39,10 @@ AC_SUBST(WARN_CFLAGS)
|
|
|
|
GUILE_PKG([2.2 2.0 1.8])
|
|
|
|
+dnl The above macro fails to set the 'GUILE_CFLAGS' and 'GUILE_LIBS'
|
|
+dnl substitution variables, hence this line.
|
|
+PKG_CHECK_MODULES(GUILE, guile-$GUILE_EFFECTIVE_VERSION)
|
|
+
|
|
PKG_CHECK_MODULES(GUILE_CAIRO, guile-cairo >= 1.4.0)
|
|
AC_SUBST(GUILE_CAIRO_LIBS)
|
|
AC_SUBST(GUILE_CAIRO_CFLAGS)
|