625492ee1a
* gnu/packages/patches/gcc-4-compile-with-gcc-5.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gcc.scm (gcc-4.7): Use it.
65 lines
2.2 KiB
Diff
65 lines
2.2 KiB
Diff
Taken from https://gcc.gnu.org/cgi-bin/get-raw-msg?listname=gcc-patches&date=2016-01&msgid=1451802493-17406-1-git-send-email-vapier%40gentoo.org
|
|
|
|
Since the 3.0.3 release of gperf (made in May 2007), the generated func
|
|
has had the gnu_inline attribute applied to it. The gcc source however
|
|
has not been updated to include that which has lead to a mismatch.
|
|
|
|
In practice, this hasn't been an issue for two reasons:
|
|
(1) Before gcc-5, the default standard was (gnu) C89, and gcc does not
|
|
warn or throw an error in this mode.
|
|
(2) Starting with gcc-4.8, the compiler driver used to build gcc was
|
|
changed to C++, and g++ does not warn or throw an error in this mode.
|
|
|
|
This error does show up though when using gcc-5 to build gcc-4.7 or
|
|
older as then the default is (gnu) C11 and the C compiler driver is
|
|
used. That failure looks like:
|
|
In file included from .../gcc-4.7.4/gcc/cp/except.c:990:0:
|
|
cfns.gperf: At top level:
|
|
cfns.gperf:101:1: error: 'gnu_inline' attribute present on 'libc_name_p'
|
|
cfns.gperf:26:14: error: but not here
|
|
|
|
Whether the compiler should always emit this error regardless of the
|
|
active standard or compiler driver is debatable (I think it should be
|
|
consistent -- either always do it or never do it).
|
|
|
|
2015-08-06 Mike Frysinger <vapier@gentoo.org>
|
|
|
|
* cfns.gperf [__GNUC__, __GNUC_STDC_INLINE__]: Apply the
|
|
__gnu_inline__ attribute.
|
|
* cfns.h: Regenerated.
|
|
---
|
|
gcc/cp/cfns.gperf | 3 +++
|
|
gcc/cp/cfns.h | 3 +++
|
|
2 files changed, 6 insertions(+)
|
|
|
|
diff --git a/gcc/cp/cfns.gperf b/gcc/cp/cfns.gperf
|
|
index 68acd3d..953262f 100644
|
|
--- a/gcc/cp/cfns.gperf
|
|
+++ b/gcc/cp/cfns.gperf
|
|
@@ -22,6 +22,9 @@ __inline
|
|
static unsigned int hash (const char *, unsigned int);
|
|
#ifdef __GNUC__
|
|
__inline
|
|
+#ifdef __GNUC_STDC_INLINE__
|
|
+__attribute__ ((__gnu_inline__))
|
|
+#endif
|
|
#endif
|
|
const char * libc_name_p (const char *, unsigned int);
|
|
%}
|
|
diff --git a/gcc/cp/cfns.h b/gcc/cp/cfns.h
|
|
index 1c6665d..6d00c0e 100644
|
|
--- a/gcc/cp/cfns.h
|
|
+++ b/gcc/cp/cfns.h
|
|
@@ -53,6 +53,9 @@ __inline
|
|
static unsigned int hash (const char *, unsigned int);
|
|
#ifdef __GNUC__
|
|
__inline
|
|
+#ifdef __GNUC_STDC_INLINE__
|
|
+__attribute__ ((__gnu_inline__))
|
|
+#endif
|
|
#endif
|
|
const char * libc_name_p (const char *, unsigned int);
|
|
/* maximum key range = 391, duplicates = 0 */
|
|
--
|
|
2.6.2
|
|
|