guix/gnu/packages/patches/nfs-utils-missing-headers.patch
Leo Famulari 606e246861
gnu: nfs-utils: Adapt to changes in glibc 2.26.
* gnu/packages/patches/nfs-utils-missing-headers.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/nfs.scm (nfs-utils)[source]: Use it.
2018-01-10 00:07:40 -08:00

20 lines
510 B
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

Fix compilation failure with glibc 2.26 caused by missing type
declarations:
------
rpc.c: In function nsm_recv_getport:
rpc.c:469:13: error: UINT16_MAX undeclared (first use in this function)
if (port > UINT16_MAX) {
------
--- a/support/nsm/rpc.c.orig 2016-08-03 20:25:15.000000000 +0200
+++ b/support/nsm/rpc.c 2017-08-26 07:41:11.884000000 +0200
@@ -40,6 +40,7 @@
#include <time.h>
#include <stdbool.h>
+#include <stdint.h>
#include <string.h>
#include <unistd.h>
#include <fcntl.h>