guix/gnu/packages/patches/kobodeluxe-midicon-segmentation-fault.patch
Stephen Webber a56145e1fa
gnu: Add kobodeluxe.
* gnu/packages/games.scm (kobodeluxe): New variable.
* gnu/packages/patches/kobodeluxe-paths.patch: New file.
* gnu/packages/patches/kobodeluxe-enemies-pipe-decl.patch: New file.
* gnu/packages/patches/kobodeluxe-const-charp-conversion.patch: New file.
* gnu/packages/patches/kobodeluxe-manpage-minus-not-hyphen.patch: New file.
* gnu/packages/patches/kobodeluxe-midicon-segmentation-fault.patch: New file.
* gnu/packages/patches/kobodeluxe-graphics-window-signed-char.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
2016-10-18 20:23:03 -05:00

25 lines
623 B
Diff

From: Emile CARRY <emile.carry@sequanux.org>
Date: Wed, 6 Apr 2016 00:27:17 +0200
Subject: midicon segmentation fault
Debian-Bug: https://bugs.debian.org/819897
Forwarded: no
---
sound/a_midicon.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/sound/a_midicon.c b/sound/a_midicon.c
index 57de3cf..ded2988 100644
--- a/sound/a_midicon.c
+++ b/sound/a_midicon.c
@@ -120,8 +120,8 @@ static inline void __press(unsigned ch, unsigned key)
{
m[ch].next[key] = -1;
m[ch].prev[key] = m[ch].last;
- m[ch].next[m[ch].last] = (char)key;
m[ch].last = (char)key;
+ m[ch].next[m[ch].last] = (char)key;
}