guix/gnu/packages/patches/gcc-asan-missing-include.patch
Ludovic Courtès 8e7ec29df4
gnu: gcc@4.8: Fix libsanitizer cross-compilation.
This patch is modified from the original patch targeting gcc@5.

* gnu/packages/patches/gcc-asan-missing-include.patch: New file.
* gnu/packages/gcc.scm (gcc@4.8)[source](patches): Add it.
* gnu/local.mk (dist_patch_DATA): Add it.
2018-01-03 23:06:44 +02:00

21 lines
766 B
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

Add missing include that triggers a build failure on PowerPC:
../../../../gcc-5.4.0/libsanitizer/asan/asan_linux.cc: In function bool __asan::AsanInterceptsSignal(int):
../../../../gcc-5.4.0/libsanitizer/asan/asan_linux.cc:222:20: error: SIGSEGV was not declared in this scope
return signum == SIGSEGV && common_flags()->handle_segv;
^
From <https://patchwork.ozlabs.org/patch/725596/>.
diff --git a/libsanitizer/asan/asan_linux.cc b/libsanitizer/asan/asan_linux.cc
index c504168..59087b9 100644
--- a/libsanitizer/asan/asan_linux.cc
+++ b/libsanitizer/asan/asan_linux.cc
@@ -29,6 +29,7 @@
#include <dlfcn.h>
#include <fcntl.h>
#include <pthread.h>
+#include <signal.h>
#include <stdio.h>
#include <unistd.h>
#include <unwind.h>