guix/gnu/packages/patches/erlang-man-path.patch
Peter Mikkelsen a4078acf4a
gnu: erlang: Fix man-pages search path of 'erl -man'.
* gnu/packages/patches/erlang-man-path.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/erlang.scm (erlang)[source]: Use it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2017-07-29 23:03:47 +02:00

25 lines
789 B
Diff

Patch originally from https://sources.debian.net/patches/erlang/1:20.0.1%2Bdfsg-2/man.patch/
by Francois-Denis Gonthier <neumann@lostwebsite.net>.
Patch description rewritten for Guix.
This patch allows access to the man page with the 'erl -man' command
(Erlang manual pages are placed to /gnu/store/..erlang../share/man/ hierarchy
as other man pages.)
--- a/erts/etc/common/erlexec.c
+++ b/erts/etc/common/erlexec.c
@@ -709,8 +709,10 @@
error("-man not supported on Windows");
#else
argv[i] = "man";
- erts_snprintf(tmpStr, sizeof(tmpStr), "%s/man", rootdir);
- set_env("MANPATH", tmpStr);
+ /*
+ * Conform to erlang-manpages content.
+ */
+ putenv(strsave("MANSECT=1:3:5:7"));
execvp("man", argv+i);
error("Could not execute the 'man' command.");
#endif