d2e1b2dac7
* gnu/packages/patches/appstream-glib-2020.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/glib.scm (appstream-glib)[source](patches): New field.
31 lines
1.2 KiB
Diff
31 lines
1.2 KiB
Diff
2020 is no longer the future.
|
|
|
|
Taken from upstream:
|
|
https://github.com/hughsie/appstream-glib/commit/953c8e529d7291e60a95e580967ed79ce2c9ccf0
|
|
|
|
diff --git a/data/tests/broken.appdata.xml b/data/tests/broken.appdata.xml
|
|
index f7a5386e..cf80f5b4 100644
|
|
--- a/data/tests/broken.appdata.xml
|
|
+++ b/data/tests/broken.appdata.xml
|
|
@@ -40,7 +40,7 @@
|
|
<p>This is a duplicate release on the same day!</p>
|
|
</description>
|
|
</release>
|
|
- <release date="2020-01-01" version="0.6.2">
|
|
+ <release date="2050-01-01" version="0.6.2">
|
|
<description>
|
|
<p>This is a release in the future!</p>
|
|
</description>
|
|
diff --git a/libappstream-glib/as-app-validate.c b/libappstream-glib/as-app-validate.c
|
|
index c1103ace..f50e4e41 100644
|
|
--- a/libappstream-glib/as-app-validate.c
|
|
+++ b/libappstream-glib/as-app-validate.c
|
|
@@ -864,7 +864,7 @@ as_app_validate_release (AsApp *app,
|
|
AS_PROBLEM_KIND_ATTRIBUTE_MISSING,
|
|
"<release> has no timestamp");
|
|
}
|
|
- if (timestamp > 20120101 && timestamp < 20251231) {
|
|
+ if (timestamp > 20120101 && timestamp < 20351231) {
|
|
ai_app_validate_add (helper,
|
|
AS_PROBLEM_KIND_ATTRIBUTE_INVALID,
|
|
"<release> timestamp should be a UNIX time");
|