guix/gnu/packages/patches/libtirpc-missing-headers.patch
Leo Famulari e522771221
gnu: libtirpc: Update to 1.0.2.
* gnu/packages/onc-rpc.scm (libtirpc): Update to 1.0.2.
[source]: Adjust patch list.
* gnu/packages/patches/libtirpc-CVE-2017-8779.patch: Delete file.
* gnu/packages/patches/libtirpc-missing-headers.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
2018-01-10 00:07:39 -08:00

41 lines
1.1 KiB
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

Fix compilation failure with glibc 2.26 caused by missing type
declarations:
------
xdr_sizeof.c: In function x_inline:
xdr_sizeof.c:93:13: error: uintptr_t undeclared (first use in this function)
if (len < (uintptr_t)xdrs->x_base) {
------
Patch copied from upstream source repository:
http://git.linux-nfs.org/?p=steved/libtirpc.git;a=commit;h=acb9a37977cf0a9630eac74af9adebf35e38e719
From acb9a37977cf0a9630eac74af9adebf35e38e719 Mon Sep 17 00:00:00 2001
From: Thorsten Kukuk <kukuk@thkukuk.de>
Date: Tue, 14 Nov 2017 10:39:08 -0500
Subject: [PATCH] Include stdint.h from xdr_sizeof.c to avoid missing
declaration errors.
Signed-off-by: Thorsten Kukuk <kukuk@suse.de>
Signed-off-by: Steve Dickson <steved@redhat.com>
---
src/xdr_sizeof.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/xdr_sizeof.c b/src/xdr_sizeof.c
index d23fbd1..79d6707 100644
--- a/src/xdr_sizeof.c
+++ b/src/xdr_sizeof.c
@@ -39,6 +39,7 @@
#include <rpc/xdr.h>
#include <sys/types.h>
#include <stdlib.h>
+#include <stdint.h>
#include "un-namespace.h"
/* ARGSUSED */
--
1.8.3.1