guix/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
nixo 3c125ac00e
gnu: julia: Fix patch.
* gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch: replaced with
  actual patch.

It was a patch creating the patch.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
2020-05-12 15:32:06 +02:00

23 lines
657 B
Diff

Fix one of upstream non-determinism, tracked here:
https://github.com/JuliaLang/julia/issues/34115
https://github.com/JuliaLang/julia/issues/25900
Patch by Nicoló Balzarotti <nicolo@nixo.xyz>.
--- a/base/loading.jl
+++ b/base/loading.jl
@@ -807,7 +807,10 @@
path = normpath(joinpath(dirname(prev), _path))
end
if _track_dependencies[]
- push!(_require_dependencies, (mod, path, mtime(path)))
+ push!(_require_dependencies,
+ (mod, path,
+ haskey(ENV, "SOURCE_DATE_EPOCH") ?
+ parse(Float64, ENV["SOURCE_DATE_EPOCH"]) : mtime(path)))
end
return path, prev
end