guix/gnu/packages/patches/gobject-introspection-cc.patch
Ricardo Wurmus 036c86be5a
gnu: gobject-introspection: Update to 1.58.1.
* gnu/packages/glib.scm (gobject-introspection): Update to 1.58.1.
[source]: Remove snippet.
[arguments]: Add phase "do-not-use-/usr/bin/env".
[inputs]: Replace python-2 with python-wrapper; add zlib.
[native-inputs]: Add autoconf and automake to be able to keep using the
gnu-build-system.
* gnu/packages/patches/gobject-introspection-cc.patch: Update patch to apply
to latest version.
2019-06-20 23:24:34 -04:00

15 lines
647 B
Diff

Use gcc as the default C compiler if CC is not set.
diff -ru gobject-introspection-1.58.1.orig/giscanner/__init__.py gobject-introspection-1.58.1/giscanner/__init__.py
--- gobject-introspection-1.58.1.orig/giscanner/__init__.py 1970-01-01 01:00:00.000000000 +0100
+++ gobject-introspection-1.58.1/giscanner/__init__.py 2018-12-03 13:33:28.788971299 +0100
@@ -22,6 +22,8 @@
builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
if builddir is not None:
__path__.append(os.path.join(builddir, 'giscanner'))
+if not 'CC' in os.environ:
+ os.environ['CC'] = 'gcc'
try:
from ._version import __version__
except ImportError: