21b3b75515
* gnu/packages/patches/glib-CVE-2021-27218.patch, gnu/packages/patches/glib-CVE-2021-27219-01.patch, gnu/packages/patches/glib-CVE-2021-27219-02.patch, gnu/packages/patches/glib-CVE-2021-27219-03.patch, gnu/packages/patches/glib-CVE-2021-27219-04.patch, gnu/packages/patches/glib-CVE-2021-27219-05.patch, gnu/packages/patches/glib-CVE-2021-27219-06.patch, gnu/packages/patches/glib-CVE-2021-27219-07.patch, gnu/packages/patches/glib-CVE-2021-27219-08.patch, gnu/packages/patches/glib-CVE-2021-27219-09.patch, gnu/packages/patches/glib-CVE-2021-27219-10.patch, gnu/packages/patches/glib-CVE-2021-27219-11.patch, gnu/packages/patches/glib-CVE-2021-27219-12.patch, gnu/packages/patches/glib-CVE-2021-27219-13.patch, gnu/packages/patches/glib-CVE-2021-27219-14.patch, gnu/packages/patches/glib-CVE-2021-27219-15.patch, gnu/packages/patches/glib-CVE-2021-27219-16.patch, gnu/packages/patches/glib-CVE-2021-27219-17.patch, gnu/packages/patches/glib-CVE-2021-27219-18.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/glib.scm (glib)[replacement]: New field. (glib/fixed): New variable.
32 lines
1 KiB
Diff
32 lines
1 KiB
Diff
From e069c50467712e6d607822afd6b6c15c2c343dff Mon Sep 17 00:00:00 2001
|
|
From: Simon McVittie <smcv@collabora.com>
|
|
Date: Mon, 8 Feb 2021 10:34:50 +0000
|
|
Subject: [PATCH 2/5] giochannel: Don't store negative line_term_len in
|
|
GIOChannel struct
|
|
|
|
Adding test coverage indicated that this was another bug in 0cc11f74.
|
|
|
|
Fixes: 0cc11f74 "giochannel: Forbid very long line terminator strings"
|
|
Resolves: https://gitlab.gnome.org/GNOME/glib/-/issues/2323
|
|
Signed-off-by: Simon McVittie <smcv@collabora.com>
|
|
(cherry picked from commit 5dc8b0014c03e7491d93b90275ab442e888a9628)
|
|
---
|
|
glib/giochannel.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/glib/giochannel.c b/glib/giochannel.c
|
|
index 0d9d5f223..4c39b9dc0 100644
|
|
--- a/glib/giochannel.c
|
|
+++ b/glib/giochannel.c
|
|
@@ -903,7 +903,7 @@ g_io_channel_set_line_term (GIOChannel *channel,
|
|
|
|
g_free (channel->line_term);
|
|
channel->line_term = line_term ? g_memdup2 (line_term, length_unsigned) : NULL;
|
|
- channel->line_term_len = length;
|
|
+ channel->line_term_len = length_unsigned;
|
|
}
|
|
|
|
/**
|
|
--
|
|
2.30.1
|
|
|