guix/gnu/packages/patches/thefuck-test-environ.patch
Eric Bavier bf5b6fb294
gnu: thefuck: Upgrade to 3.15 and enable tests.
* gnu/packages/patches/thefuck-test-environ.patch: New patch.
* gnu/packages/admin.scm (thefuck): Upgrade to 3.15.
[source]: Use patch.
[arguments]: Remove '#:tests? #f'.  Move 'check' phase after 'install'.
* gnu/local.mk (dist_patch_DATA): Add patch.
2017-03-29 20:51:06 -05:00

15 lines
404 B
Diff

Retain environment setting of "HOME" for tests that need os.path.expanduser()
to return a readable directory in the build chroot.
--- thefuck-3.15/tests/test_conf.py
+++ thefuck-3.15/tests/test_conf.py
@@ -12,7 +12,7 @@
@pytest.fixture
def environ(monkeypatch):
- data = {}
+ data = {"HOME": os.environ.get("HOME")}
monkeypatch.setattr('thefuck.conf.os.environ', data)
return data