guix/gnu/packages/patches/sbc-fix-build-non-x86.patch
Marius Bakke 85ba5e9335
gnu: sbc: Fix build on non-x86 architectures.
* gnu/packages/patches/sbc-fix-build-non-x86.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/linux.scm (sbc)[source](patches): New field.
2020-12-21 23:38:22 +01:00

18 lines
562 B
Diff

Don't refer to x86-specific function on other architectures to avoid linker error.
Submitted upstream at <https://marc.info/?l=linux-bluetooth&m=160857625608440&w=2>
diff --git a/sbc/sbc_primitives.c b/sbc/sbc_primitives.c
--- a/sbc/sbc_primitives.c
+++ b/sbc/sbc_primitives.c
@@ -593,7 +593,9 @@ static int sbc_calc_scalefactors_j(
static void sbc_init_primitives_x86(struct sbc_encoder_state *state)
{
+#if defined(__x86_64__) || defined(__i386__)
__builtin_cpu_init();
+#endif
#ifdef SBC_BUILD_WITH_MMX_SUPPORT
if (__builtin_cpu_supports("mmx"))