751702676e
In glibc-2.25 a dependency on "linux/falloc.h" was added.
This also reverts commit 8f8f250bdc
which is no longer needed. This commit was not compatible with
the glibc version Hurd is using. See
<https://lists.gnu.org/archive/html/guix-devel/2017-02/msg01046.html>
* guix/build/make-bootstrap.scm (make-stripped-libc): Copy "falloc.h"
to the new system.
* gnu/packages/patches/glibc-bootstrap-system.patch: Remove part
that touches fcntl-linux.h.
Problem reported by Andreas Enge <andreas@enge.fr>.
30 lines
1,023 B
Diff
30 lines
1,023 B
Diff
We want to allow builds in chroots that lack /bin/sh. Thus, system(3)
|
|
and popen(3) need to be tweaked to use the right shell. For the bootstrap
|
|
glibc, we just use whatever `sh' can be found in $PATH. The final glibc
|
|
instead uses the hard-coded absolute file name of `bash'.
|
|
|
|
--- a/sysdeps/posix/system.c
|
|
+++ b/sysdeps/posix/system.c
|
|
@@ -134,7 +134,7 @@ do_system (const char *line)
|
|
INIT_LOCK ();
|
|
|
|
/* Exec the shell. */
|
|
- (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ);
|
|
+ (void) __execvpe (SHELL_NAME, (char *const *) new_argv, __environ);
|
|
_exit (127);
|
|
}
|
|
else if (pid < (pid_t) 0)
|
|
|
|
--- b/libio/iopopen.c 2012-06-30 21:12:34.000000000 +0200
|
|
+++ b/libio/iopopen.c 2012-12-19 12:52:29.000000000 +0100
|
|
@@ -226,7 +226,7 @@ _IO_new_proc_open (fp, command, mode)
|
|
_IO_close (fd);
|
|
}
|
|
|
|
- _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0);
|
|
+ execlp ("sh", "sh", "-c", command, (char *) 0);
|
|
_IO__exit (127);
|
|
}
|
|
_IO_close (child_end);
|
|
|
|
|