guix/gnu/packages/patches/source-highlight-regexrange-test.patch
Eric Bavier 583103416d gnu: Add a2ps, trueprint, enscript, and source-highlight
* gnu/packages/pretty-print.scm: New file
* gnu/packages/patches/source-highlight-regexrange-test.patch: New file
* gnu-system.am (dist_patch_DATA): Add patch.
(GNU_SYSTEM_MODULES): Add pretty-print.scm
2014-03-07 10:11:12 -06:00

16 lines
553 B
Diff

Disable a single check. The failure is discussed at:
https://savannah.gnu.org/bugs/index.php?41786
--- a/lib/tests/test_regexranges_main.cpp 2012-04-14 08:58:25.000000000 -0500
+++ b/lib/tests/test_regexranges_main.cpp 2014-03-05 23:49:23.520402043 -0600
@@ -52,7 +52,7 @@
check_range_regex("simple regex");
check_range_regex("[[:alpha:]]+");
// test with a wrong regular expression
- check_range_regex("{notclosed", false);
+ // check_range_regex("{notclosed", false);
// reset regular expressions
ranges.clear();