5387a9c00e
Fixes: <https://issues.guix.gnu.org/issue/52784>. * gnu/packages/wm.scm (xmonad-next): New variable. Compared to xmonad: Update to 0.17.0. [inputs]: Add GHC-DATA-DEFAULT-CLASS, remove GHC-EXTENSIBLE-EXCEPTIONS, GHC-DATA-DEFAULT, GHC-SEMIGROUPS, and GHC-UTF8-STRING. [native-inputs]: Add GHC-QUICKCHECK and GHC-QUICKCHECK-CLASSES. (ghc-xmonad-contrib-next): New variable. Compared to ghc-xmonad-contrib: Update to 0.17.0. [propagated-inputs]: Remove GHC-OLD-TIME, GHC-EXTENSIBLE-EXCEPTIONS, GHC-SEMIGROUPS. [native-inputs]: Add GHC-QUICKCHECK and GHC-HSPEC. (xmonad): Inherit from xmonad-next. (ghc-xmonad-contrib): Inherit from ghc-xmonad-contrib-next. * gnu/packages/patches/xmonad-next-dynamic-linking.patch: New patch. Update of xmonad-dynamic-linking.patch to apply to xmonad-next. * gnu/local.mk: Add it. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
16 lines
513 B
Diff
16 lines
513 B
Diff
This patch is required for xmonad to make use of shared libraries.
|
|
Without it, xmonad will not work since we do not (by default) use
|
|
statically linked Haskell libraries.
|
|
|
|
index 46a0939..5ad4f8f 100644
|
|
--- a/src/XMonad/Core.hs
|
|
+++ b/src/XMonad/Core.hs
|
|
@@ -664,6 +664,8 @@ compile dirs method =
|
|
where
|
|
ghcArgs = [ "--make"
|
|
, "xmonad.hs"
|
|
+ , "-dynamic"
|
|
+ , "-fPIC"
|
|
, "-i" -- only look in @lib@
|
|
, "-ilib"
|
|
, "-fforce-recomp"
|